Official Thimbleweed Park Forums

Achievement Not Unlocking

Not a big deal but on the X1 version neither the Part 1 or Part 2 achievements ever unlocked despite me finishing the game. Great game. Really enjoyed it!

Hi. I am curious. What are achievements and what does it mean that they should be unlocked? I’ve finished the game, but I have no clue what your questions means which makes me feel that I have missed something.
D.

Hey Diessoli

There are two achievements… Literally named “Part 1” and “Part 2” . As I read, they are supposed to unlock once you start Chapter 1 and 2 respectively. Basically unavoidable achievements that didn’t pop for me for some reason.

There is a “bug” with achievements, where if you’re offline when you get “part 4”, then are online when you get “part 5”, you won’t get part 4. The achievements are tracked and stored locally, but not retransmitted once online. This has been fixed in the next patch.

I don’t know if this was your issue.

Some gaming platforms, like Steam, give to the developers a way to add “achievements” to their games. They are a sort of “badge” that the platform gives to players who have reached a specific point in the game or who did something special. Some players try to get the full list of achievements that the developers have planned for the game.

Where’s achievements of iOS version

We did not implement achievements in iOS.

Has this bug been fixed yet? I got the same problem that my game hasn’t updated the achievements and progress stats, like dust collected, while I was offline. While I’ve been online, nothing has synced anymore, just got more dust and it’s still only showing the same amount I got before I went offline.

Oh I should add that I’m using the Windows 10 version (0.7.2.2) : 1410.938 (from the options screen).

From experience, the achievements on Windows 10 can sometimes stop appearing or be delayed and it’s not caused by the game itself. A few suggestions:

  1. The “Connected User Experiences and Telemetry” service in Windows may be disabled on your computer, which is causing the issue. You can fix this by pressing Windows Key + R -> typing: services.msc -> finding Connected User Experiences and Telemetry -> changing startup type to: Automatic. Then restart your computer and launch the game.
  2. If that doesn’t work, try updating your OS. It’s possible that something in your version of Windows 10 is preventing the achievements/statistics from being correctly updated.
  3. Try logging out of your Xbox App, restarting your computer, and logging back in.
  4. You can also try uninstalling and reinstalling your Xbox App. Here’s some information on how to do that (it’s a bit more complicated, as it’s a default system app):
    https://winaero.com/blog/how-to-uninstall-and-remove-the-xbox-app-in-windows-10/
    https://www.cnet.com/how-to/how-to-reinstall-default-apps-in-windows-10/
1 Like

Thanks for the advise, but sadly none worked. I even downloaded the beta xbox app, but still no dice…

I am on an insider build, so that might have something to do with it, but I tried another game and it seemed to work fine while offline.

Also, the save game to the cloud feature is working perfectly, and I was able to download the save game to my xbox, but again, I’m in Chapter 3, but am missing it’s achievement and another. Plus it says I’ve read no books, which is a lie as I read some in a flashback that I completed…

Hmm, sad to hear that nothing worked. :frowning:

I think the insider build might have something to do with it. IMO, this is some OS (or Xbox Live) issue that we can’t do much about, unfortunately. There was a period of time when my achievements and statistics weren’t popping up and getting updated either (and I was unable to resolve this). Then it mysteriously “fixed itself” after some time and to this day, I’m not sure what was the source of the issue. But I know I updated Windows 10 in the meantime.

Official Thimbleweed Park Forums powered by Discourse.