Official Thimbleweed Park Forums

Delores Thimbleweed Park Mini-Adventure game. Game does not start. Any idea?

Hello!

I just recently finish Thimbleweed Park and I noticed that there is an expansion with Delores - A Thimbleweed Park mini-adventure!!!

But I am not be able to start game (running via my Steam account). I have a laptop with i7 (3rd generation), GeForce 610 2GB card, 16 GB RAM and Win10 x64 up-to-date with DirectX 12.

When it starts, it loads the window, but finally disappear, without running the game. I tried to run game in Win10 in mode failsafe, and in this setting, game runs OK!

I checked if there any update from Windows, Graphics card, etc and all seems up-to-date. Any idea? Regards!

1 Like

Hello,

sorry to hear that you’re experiencing technical problems. From the information you’ve provided, the game should run just fine on your setup.

Can you describe in more detail what’s happening when you try to run the game? Is some window opening and immediately closing? Are you seeing only a black screen? Is the game still running in the Task Manager, or does it quit itself straight away?

Can you try the following?

  1. Run the game in safe mode.
  2. Switch it to windowed mode via the Options (you can just press “O” on your keyboard and uncheck the checkbox next to “Fullscreen”).
  3. Quit the game.
  4. Try running the game normally.

Does this “fix” the issue?

Hello!

Trying run game in safe mode, works (works in windowed mode and full screen mode).

Then, I change to leave windowed mode setting, but when I restart PC in normal mode (not safe mode), the game runs and some window opens and inmediately closes. Monitoring in task manager, I can see the process “Delores” and then, after the windows disappear, the process in task manager, also dissapear.

Is there a way to fix via settings to maintain windowed mode that works in safe mode?

Thanks for the information!

It seems that the fullscreen mode isn’t causing the problem, so switching to windowed mode probably isn’t needed after all.

Is it possible that your firewall or antivirus program may be blocking the game from launching? Same question for @Gffp , who seems to be experiencing the same issue.

Sorry, I tried putting off antivirus/firewall and did not work, too. Maybe is there a way to force put game in windowed mode (in launching options with the steam launcher, for example)?

I search preferences file (in C:\Users<MyWindowsUser>\AppData\Roaming\Terrible Toybox\Delores). There is a file (Prefs.json) with options enable, like not full screen mode:

booted: 1591212094
hoverBeep: 1
hoverPop: 1
sayLineSpeed: 1
smallFont: 0
volume_effects: 1
volume_master: 1
volume_music: 0.5
volume_voice: 1
windowFullscreen: 0 <<<< This is the option that I modified in safe mode, and was working in safe mode, but when I run game in normal mode, besides of putting this configuration, games did not start like I explained
windowPosition: (43,24)

Some file in C:\Users<MyWindowsUser>\AppData\Roaming\Terrible Toybox\Thimbleweed Park, takes a similar config (with more options) and works great, running my Thimbleweed Park game in full screen mode or windowed mode.

One idea: like I explained before, this is installed via Steam (I have many games there).

I checked the windows path where game files are stored and I have these files:
imagen
(Path: C:\Program Files (x86)\Steam\steamapps\common\Delores)

Maybe fails any file or is there a missing file? Please, could you check your windows path for the game and check if it is the same or not?

Regards!

You’re absolutely right that this Prefs setting controls if the game launches in fullscreen/windowed mode, but it doesn’t look like this is a viable “solution” to this particular problem (since it doesn’t seem to be resolution-related or such). It seems more like the game is somehow being prevented from launching.

I’ve messaged you with something else you can try. Let me know via DMs if this perhaps worked.

As for Steam and missing files - if any file was missing, the game wouldn’t be able to start either in standard mode or safe mode. Since it can start in safe mode, this points to some other root cause. I’ve checked and everything on your screenshot looks fine - nothing is missing and the file sizes are also correct.

EDIT
I only use the antivirus and firewall built in Windows 10 (1909). ̶B̶u̶t̶ ̶I̶’̶m̶ ̶o̶n̶l̶y̶ ̶a̶b̶l̶e̶ ̶t̶o̶ ̶d̶i̶s̶a̶b̶l̶e̶ ̶t̶h̶e̶ ̶f̶i̶r̶e̶w̶a̶l̶l̶,̶ ̶n̶o̶t̶ ̶t̶h̶e̶ ̶a̶n̶t̶i̶v̶i̶r̶u̶s̶.̶
I managed to disable built in firewall and antivirus but still, this setup does not solve the problem. I also disabled a MS thing called “Defender Smart Screen”, which should protect the machine from undesired software :thinking:. Anyway, still nothing. (Despite months of use, a lot of things in Windows 10 are completely new to me).
The fact that the game runs fine on safe mode is a mistery to me, but still, better than nothing :slightly_smiling_face:.
Check DM for further informations on the steps you suggested.
Hope this helps.

Official Thimbleweed Park Forums powered by Discourse.