Official Thimbleweed Park Forums

Failing to load the OBB file (Android)

This was fixed in 1.0.1, but if you still have 1.0.0, just reboot your device and all will be well.

My lack of respect for authority pushed me to modify your topic and add a useful information.

4 Likes

This is dangerous - we could make Ron say all sorts of things :smile:

Hi Ron, I just bought the game but i get the OBB error I tried rebooting but its still the same ?
using a MiBox
thanks in advance
jon

@jonibee:

Thanks for getting in touch. Are you able to answer the following questions to help eliminate possibilities?

  1. Does your device have enough free storage to install the game correctly?

  2. Which model MiBox do you have?

  3. Which version of Android is running on your MiBox?

  4. Does the MiBox have the Google Play Store on it and are you installing it directly from there? If not, are you side loading the game?

  5. Can you check for the presence of the OBB file in the ‘/sdcard/Android/obb/com.terribletoybox.thimbleweedparkandroid’ folder? (You may need to download an Android file browser to navigate to this folder.

Thanks!

Rob

How did I miss this awesomeness? :smiley:

I had this error after the latest update. The permissions for the app were wrong for some reason. All I had to do was enable permission for storage in the app into (android 7 I’m using) and it worked again without error

Hmmm, interesting. So you didn’t need to reboot your device? Am I assuming correctly that you went to Settings -> Apps -> Thimbleweed Park - and saw that Permissions (Storage) was turned off (and turning it back on fixed the problem)?

1 Like

Yep, that’s exactly it.

I didn’t reboot, mainly because I’d only just switched my tablet on so rebooting seemed pointless.

When I saw somewhere (I think this forum) that it was a permissions error, I checked what permissions were granted and spotted this

1 Like

This actually helps quite a lot. Thanks, Chris! It seems like rebooting doesn’t fix the problem for some users (and for some, it does). It’s quite a frustrating issue. I hope that either rebooting or manually turning Permissions (Storage) on should resolve it for everyone.

1 Like

Hi,

i changed from Galaxy S8 to Pixel 4, but now I also get the error message.
Deleting all app data, reinstalling and rebooting doesnt help.
I’m on the current play store version (1.0.7).
Any help appreciated!

Thanks
Max

Hello Max,

this is a new issue (unrelated to the initial posts in this topic) that started occurring for some users on Android 10.

So far, we haven’t been able to reproduce this issue ourselves on several Android 10 devices, so that makes it a bit difficult to solve. We’re definitely looking into it, but because of this, it’s been taking longer than expected.

From logs that one user kindly sent us, we managed to find out that downloading of the OBB file succeeds, but then the Google Play app fails to move the downloaded file to the final location. We are still not sure why that happens, but it seems like there’s something strange going on with the Google Play app on Android 10 and it sometimes doesn’t work as it should.

A few steps to try are:

  • Firstly: clearing the cache and data from the Google Play Services and from the Download Manager. The related steps for both can be found here: https://support.google.com/googleplay/answer/7512202?hl=en (under Clear cache & data from Google Play Services and Clear cache & data from Download Manager). Clearing the Google Play Services cache and data has recently worked for some users, so it’s the most important step to try from all of these.

  • Similarly, try clearing the Play Store cache + data. The steps are described on this website (look at Step 2: “Clear the cache & data of the Play Store”): https://support.google.com/googleplay/answer/7513003?hl=en .

  • Taking a look in the Permission Manager to see if there is something specific set up for Thimbleweed Park. The steps to do this are described on this page: https://www.androidauthority.com/android-10-permissions-1040121/ (under How to view and change Android 10 permissions). There are also some other steps related to permissions described under Other tips and tricks on that site.

    • Is the Thimbleweed Park app being denied permissions anywhere, by any chance? The app itself only requests Storage permissions, but if these are denied anywhere, then the OBB file wouldn’t be able to get installed properly.
  • Updating your Android OS to the latest version (installing any updates that are available, even minor ones).

  • Checking if your Google Play app is up to date: https://www.androidpit.com/google-play-not-working#update-google-play

  • Checking the separate Google Play Services app and see if that might need updating: https://www.androidpit.com/install-google-play-services-apk

  • Making sure that Download Manager is enabled (it’s mentioned on this page: https://www.androidpit.com/google-play-not-working)

  • If all previous steps fail, you can also try deleting the folder where the OBB file should go and then downloading again. Search for the folder by using the Android “Files” app. You’ll need to tap the 3 dots in the top right and make sure “Internal Storage” is visible. Then in the search bar, just put “obb”. You should see an OBB folder. Within that there will be a folder for “com.terribletoybox.thimbleweedparkandroid” (this folder should normally contain the OBB file, but is probably empty for you). Delete this folder and try downloading the game again.

If none of these steps work, please shoot us an e-mail at support@thimbleweedpark.com and we’ll do our best to help you out.

3 Likes

Thanks a lot, now it works again.
just for you other guys, this is what i did:

  • Uninstall twp
  • clear cache and data of google play services
  • delete obb folder on internal storage
  • reinstall twp
  • add rights to file access to twp (long press app, info, …)
  • start twp.

Now only my progress is lost :confused:

Thanks a lot!
Max

3 Likes
Official Thimbleweed Park Forums powered by Discourse.