Official Thimbleweed Park Forums

Orientation problem on iPad

The game does only use one fixed orientation. Which is bad, because if you use headphones on an iPad, the plug is on the lower left. That’s where your Hand is. But you can’t turn it around because the game don’t notices the orientation.

Oh shoot! That’s true, the game doesn’t seem too to react to the changing orientation! :scream:

There’s a work-around, though: change orientation before starting the game and it should honour it. Oops! Except it doesn’t stay out and flips back!!!

dZ.

This doesn’t work on Android - even you change the orientation of the device BEFORE starting the game the game itself will start in FIXED orientation.
See my previous post on this https://forums.thimbleweedpark.com/t/android-build-0-8-14/1445/34?u=pecatb

Same in iOS, I just tested it. :frowning:

Hi @Lemnyy

Thanks for posting, we aren’t seeing this on any of our testing devices. The portrait lock is the only think I can think of that would stop this.

Can I get you to swipe up from the bottom of the screen and double check that portrait lock is off?

Ahh… interesting. Yep it was unlocked… buuuuut… if you toggle it on and off again it while the game was running, it now senses the rotation. Even after restart.

Nice… soveld it for me. :slight_smile:

On the iPad, I can confirm that the orientation lock is not set. I have it assigned to the physical button on the right side and flipping it while the game is running shows the indicator switching on and off, but has no effect on the game.

Also, as I mentioned above, I can change orientation outside the app, and then it flips by itself when I run it.

@DZ-Jay Try toggling it while the game is running. Fixed it for me.

I did, no help. :frowning:

I even changed it from the physical toggle to the Control Center software button and no dice.

Did not help on Android as well (Samsung S7 Edge and Nvidia Shield tablet, both Android 7 )

Make sure you have iOS version 1.0.1. In the first build (1.0.0) rotation was not working.

I have still the latest 10.x build. I always wait a few days until the dust has settled. :slight_smile:

What build do you have?

iOS 10.3.3 (14G60)

What build of Thimbleweed Park, not iOS.

1.0.0 or 1.0.1

1.0.1 has rotating, 1.0.0 does not.

Ah… sems to be 1.0.0, but the rotation thing is working after toggling it while running the game.

PS: OMG :scream: just realizing… Ron himself… what an honor. With Thimbleweed Park you have brought back all the positive feelings of my childhood about these games.

1 Like

In 1.0.0 we were not listening for the rotation notification correctly. I’m surprised it worked at all, but it’s fixed in 1.0.1 and should work fine.

1 Like

Just updated to 1.0.1 and can confirm that the issue is fixed. :+1:

Official Thimbleweed Park Forums powered by Discourse.