Official Thimbleweed Park Forums

For those who've completed the game, what was the hardest puzzle?

For me, it was how to navigate the woods to the secret meetup. I knew it was in the woods because I’d see random people walking in, but I couldn’t for the life of me figure out how to navigate it.

I was 99% sure I’d have to look up the solution (so far I hadn’t looked up anything), but then I had a sudden inspiration and solved the puzzle at last! I have to admit it feels great to do that – but that one was tough!

6 Likes

Glad you peservered, figured it out, and got the satisfaction of solving it!

2 Likes

For me it wasn’t a puzzle per se, more trying to complete puzzles that couldn’t be completed until a later act.

4 Likes

I was stuck there too. I only discovered it by accident when I tried out the acid with everything. Walked around for 10h while being stuck, trying everything to get the crystal, because I thought I would have to finish Franklin’s to do list to proceed. The encounter with the pizza guy was so short and I forgot about him and the flyer with the meet-up hint.

4 Likes

For me it was getting the Pigeon brothers to come to the hotel. I knew how to scare the guest and that I should somehow get the hotel manager to call the Pigeon brothers, I just didn’t know how to do it.

I didn’t hit many puzzles that really were too hard; adventure games have taught me to drop it and focus on something else if one puzzle can’t be solved. But I did spend quite a lot of time trying to figure out how to get change for the dime, only to realize I just had to recycle the bottle. Felt pretty dumb after wasting so much time haha

2 Likes

To me, memory was my biggest downfall. Since I played through the game an hour or 2 at a time, It gave my aging brain time to forget about key stuff that It just couldn’t remember… like that Thimbleberry pie.

2 Likes

Actually, the hardest thing for me was getting the watch tools, I tried everything with everyone on the door until I got the solution just by grinding through. Leaving the door open while the guy was in there really threw me off the scent

Speaking of the woods - really liked the navigators head! - and how reminiscent it was of the woods in mi1

2 Likes

For me it was the fact that I didn’t see I could “open” the cheque book in the uncle’s office. I lost like one hour to visit every room in the game and finally I figure it out.

1 Like

I had difficulty with the same puzzle – finding the secret meetup / charging the battery on the fence. I was in one of those places where I had wandered around for hours and just wasn’t sure which puzzle I needed to be solving. I really suspected that Franklin was going to ‘zap’ the battery into life, so I just kept trying to figure out where I needed to put the battery down in the hotel so that he could access it. Wasted a lot of time on that endeavor! I did eventually look at some hints for the battery, and I’m glad I did – I don’t think I would have figured that one out even if given a long time.

I also wasted a lot of time having Ransome jump on the trampoline before there was a reason for him to be jumping. I was convinced that I had to click on one of the objects at the exact right time for something to happen, so I just kept switching which side the trampoline was on and clicking at different points again and again and again. Then when I did finally get into the safe, I felt pretttyyyy dumb.

1 Like

Only time I ever got stuck was when I didn´t think to just open the cash register. I wanted to take it with me, I tried to use it, just never thought to just open it. That was really about the only time I got seriously stuck.

1 Like

The one part I really got stuck on was the reading of the will. There are hints about where you would get the pie, but those were in the past and forgotten by the time I needed them.

I also thought the Graphics BASIC item looked like a device already connected to the computer and didn’t understand you could pick up and use it.

For me it was the radio station. I had most of it figured out, but there were so many steps and sequencing that it became confusing. In particular, rebooting the radio station’s phone system was unclear to me. Perhaps I missed something along the way.

There were some others that I had some problems with, but mostly due to me trying something too early and then assuming that item was a red herring. There were a lot of them in this game.

I suppose it’s not really a puzzle, bit I had to look up where to find the book Franklin needed. I overlooked it the first time I was in its location and was disinclined to visit that location again.

4 Likes

Finding the fingerprint tape. I was stuck for hours.

2 Likes

Yes, me too, I knew where it was, but struggled to actually get it

It didn’t occur to me, that Franklin could simply zap the door to Sexy Riker’s Hotel Room. Spend lots of time trying to enter the room with different characters, while he was vomiting. Had to look it up at last :frowning:

3 Likes

Agreed. I really thought it was a puzzle where I had to ask for a particular book, and when I finally realised you just had to find it at the top of the shop I felt like the puzzle was mean.

1 Like

Getting the map. It took me a long time. Also the wrench was as hard for me.

I got stuck the longest in getting the Map from the Nickel… It’s bad, since I think it’s one of the most logical puzzles in the game.

Official Thimbleweed Park Forums powered by Discourse.