Official Thimbleweed Park Forums

Linux build 121208

One… more… time. Twelfth time is a charm!

5 Likes

yay :slight_smile:

Linux Mint 20 + Nvidia 440.100 works Ok with sound disabled.
When I enable sound I still get the FMOD error and game aborts.

Works here with Archlinux + Nvidia. Both sound and game work now.

Works for me too, on Pop!_OS (Ubuntu) 20.04, with both Intel and Nvidia (full specs in this post), including sound effects and music! :grinning: :yellow_heart: Logs are identical for both GPUs, and contain no errors or warnings. :+1:

W00t!

I don’t know how to deal with the sound issue. FMOD does all of that and it’s a black box in a precompiled .so file. I’ll see if there is a debug mode it can be put into so you can get more information.

On my laptop (Kubuntu 20.04 with Intel graphics), Delores runs fine if I run it from the command line. But if I start it through Steam, I also get the audio error mentioned above:

Screenshot_20200917_143912

Based on that, I found the possibly relevant:
https://github.com/ValveSoftware/steam-for-linux/issues/2968 (but I have libpulse0:i386 installed and in a couple of other games I randomly tried sound works fine when started through Steam)

Output with Steam on the command line:

ALSA lib pcm_dmix.c:1029:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:1029:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:1029:(snd_pcm_dmix_open) unable to open slave
[14:46:43] FMOD error! (51) Error initializing output device.

Not sure if that long thread mentioned this, but try setting the environment variable FMOD_ALSA_DEVICE = default. Like I mentioned above, FMOD is a black box. You can always set Delore pref in Prefs.json to disableAudio: 1, but then there is no audio.

This is from FMOD about the issue:

The logging version of FMOD is the main way to get more information about what’s going wrong. As for things to try, FMOD will make a choice between using PulseAudio or ALSA as the audio interface based on the response from pulseaudio --check . If PulseAudio is available it will use it otherwise it will fallback to using ALSA.

You can influence this choice (as a user) if PulseAudio is misbehaving. Use of the environment variable FMOD_ALSA_DEVICE allows you to specify an ALSA device to use instead of the default. Setting FMOD_ALSA_DEVICE = default should force the game to use the ALSA default device or any valid ALSA device name if that’s your preference.

1 Like

There is if you bypass Steam though, at least on my laptop, maybe that got lost a bit in my message. :slight_smile:

Running steam with a variation of the suggested environment variable (for Delores/FMOD) does result in sound. That is, FMOD_ALSA_DEVICE=pulse steam or pasuspender steam.

But I discovered the cause for this issue on my laptop was actually the workaround for the fact that Steam insisted on downloading the Windows version! After unchecking the force “Steam Linux Runtime” box it works. I can only assume it overrides some system libraries causing trouble. :confused:

1 Like

Odd. I don’t think I can fix anything, but it’s good info for support to know.

good info. It seems that FMOD is relying on an unofficial pulseaudio feature?

$ pulseaudio --version
pulseaudio 13.99.1

$ pulseaudio --help
...
 --check                           Check for a running daemon (only returns exit code)
...

So --check does not return the name of backend. It just returns a code.

Thanks Frenzie. This solved my issue. Game running Ok now! :slight_smile:

FMOD_ALSA_DEVICE=pulse steam

I missed the last few builds, but I just wanted to report that the current build works great! No issues at all on Mint 20 for me.

Same here, works for me now. :tada:

Just wanted to let you know that this build is working great for me as well, got my first five photos, it’s nice to be revisiting Thimbleweed Park.

Thanks!

1 Like

Great! Thanks everyone for all your help.

5 Likes
Official Thimbleweed Park Forums powered by Discourse.