New update for Thimbleweed Park: build 938

At which part of the game are you?
I think (not sure, but it’s reasonable) that this object is visible after a certain part has occurred.

Got saves in part 3, 4 and at the very end (which blocks you from many areas). I concentrated my search on the midgame parts, though.

Oh FFS is it after the will reading? Right, don´t got the nerve to play up to that part now (I got a save several hours before and another one AFTER that).

Too early.

I think so. :slight_smile:

Load the savegame after part 5, and wander around.

1 Like

Thanks anyway.

That one has the ending music playing already and Delores is the only character left. And it seems the Mansion Mansion is inaccessible at that point. So all I´d have to do is play up to Part 6 it seems and I just cannot be bothered at the moment.

1 Like

I feel you already figured out what to search… am I wrong?

Absolutly, I´ve pretty much known that for weeks now. Just didn´t figure I´d have to replay half the game now to get there. I´d have kept a save in part 6 had I know that it works that way.

Hindsight is a bitch…


Isn’t it devilishly ironic that all that knowledge wasn’t enough to make you one of the first people to play the arcade games? :grin:

I´m pretty much writing my entire biography with irony that eventually ends up biting me in the arse.

Drawn from life

1 Like

Has somebody already played the arcade games on Casual mode? Is the above mentioned object necessary to play the games?

The arcade games can only be played on Hard mode. It requires an object and an Easter egg which are only available in Hard mode.

1 Like

Thanks! I assumed that on Casual mode the developers would have made it possible to play the arcade games without solving any puzzle.

I believe it is intended to be an Easter Egg for hardcore gamers (harking back to Maniac Mansion).

That’s strange. I have just tried my old savegames of the casual playthrough and I’m able to enter the arcade and just play the games. Didn’t it work for you?

Really? I had not tried in Casual mode yet because I didn’t have a save have at the appropriate moment. I was just basing it on what I heard. I guess that was wrong. Cool!

He must mixing up hardmode/casual with annoying in jokes on/off.

Anyway, I tried the three games now.


So i found the object but i don’t really know where to use it, any hint? Maybe i don’t know the easter egg you are talking about

I have replied to you in this new thread in the “Hints” section.

Thanks! found it!

How can I play the games on the other (broken) machines? I tried to take off the “out of order” sign, but it didn’t work.


I may be wrong, but I don’t think it’s possible. The arcade room, like almost any other place in the town is in awful conditions and even the pinball that you can see in the foreground is broken. I think that the broken games were intentionally made this way to convey a sense of abandon (and also to save development resources :stuck_out_tongue: ).