Official Thimbleweed Park Forums

Problem when the mouse is at the right-most side of the screen


When moving my mouse to the right of the screen (so that I cannot move it more to the right), clicking on the left button won’t work. I have to move it just a pixel from the right of the screen for it to work.

The problem doesn’t appear on the left side of the screen.

This is really annoying when trying to make the game scroll: when I want to do that I tend to move the mouse to the right-most side of the screen, so scrolling doesn’t work until I move my mouse again to the left.

I am using a Surface Book with Windows 10 (with latest updates), the game is running in full screen mode and it’s the Steam version.

Not sure it matters, but I have bought the bip DLC.

PS: mouse = Surface Book’s trackpad.


Hi, I’ve checked playing on a PC with Windows 10, Steam version, fullscreen and with Ransome DLC, and I don’t have the issue you described.
When the cursor is on the far right edge, clicking the left mouse button moves the current character.

Maybe it’s something related to the surface book?

Do you have the same issue using software other than Thimbleweed park?


I don’t have such problems in any other games/apps.

Also, I have no problems with the Microsoft Store version of Thimbleweed Park on the same computer: moving the mouse on the far right edge of the screen and clicking works as expected.

More information:

  • Thimbleweed Park Steam version 1421.958: doesn’t work
  • Thimbleweed Park Microsoft Store version ( 1410.938: works


I did so more tests and noticed the problem seems to be related to the scaling property of the screen Thimbleweed Park is ran on.

The Surface Book’s screen is 3000 x 2000 pixels screen and the scaling is set to 200% by default (that’s the recommended scaling).

  • when using 200% scaling, I have the bug
  • when setting the scaling to 100%, the bug isn’t present anymore

The setting can be accessed by opening the settings app -> system -> display:


I think I found a workaround (setting the Windows’ screen scaling to 100% on such a high DPI display is not a solution because it makes everything so tiny).

When right-clicking of ThimbleweedPark.exe and chosing properties then going to the “compatibility” tab, and changing the scaling property this way fixes the problem:

I also think it’s not specific to the Surface Book but should happen on any Windows 10 machine with a HDPI screen and scaling > 100%.


That’s an odd one. Thanks for doing some research and posting. Given the game is fullscreen, I can’t imagine the situation where windows would not be passing us a mouse click. I test Windows on a Surface, and I’ve never seen this, I’ll boot it up and check my scaling values.


One last thing I forgot to mention: I am running Windows 10 “Fall Creators Update”, that’s the latest stable Windows 10 version.

I know they tweaked some things related to scaling/display on HDPI in this version so maybe the bug doesn’t appear in earlier Windows 10 version?


I’ve tested it with the GOG Version (1421.958):
On Windows 8.1 with DPI scaling enabled this issues doesn’t seem to exist.

Btw. for this game you should always disable scaling anyway because otherwise it scales the precious pixels making them blurry.
Maybe @RonGilbert could fix this issue + the scaling issue by playing around with the DPI Awareness setting in application manifest (also see High DPI Desktop Application Development on Windows). He is doing his own scaling anyway.


My life goal is to know as little about Windows as possible.


Changing the compatibility settings of the app isn’t a solution after all: it makes the app slugging in fullscreen. I hadn’t noticed, but when activating this option (see the screenshot in my previous post), the mouse pointer is sluggish and the scrolling becomes jerky and I can see the screen being refreshed, like there was no vsync.

If I disable this option and restart the game it’s smooth again, but the mouse click problem is back :confused:

I guess I’ll have to avoid clicking on the edge, like keeping mouse down and moving the mouse.


This is a Surface Book? Not a Surface Pro? I have a Surface Pro and don’t see this behavior, which I don’t need to do. Mine is 200% at 2736x1824. Windows 10 Pro v 1709 build 16299.309


Did you try the version 1421.958 on Microsoft Store, just to rule out if the issue is caused by either the version of the game or the way the game is launched by different wrappers? (Make a backup first, so you at least have access to the working version. Why do you have two windows copies, BTW?)


This is a Surface Book. This may sound odd, but could you try changing the accent color of Windows and try again ?


Why do you have two windows copies, BTW?

I first bought the Windows Store / Xbox version and since the unbeeped DLC was only available on the Steam version I bought it again on Steam.

I also bought the Android version because I like the idea of having the game in my pocket :slight_smile:

Fortunately I don’t have a Switch or PS4… yet :slight_smile:


I’ll do that. But it seems both versions don’t act the same: when running the Steam version fullscreen and pressing alt tab, I can see Thimbleweed Park running in the background, and some windows and the taskbar overlap it, just like it was using some sort of overlay mode.

This does not appear in the store version.

Maybe the problem has nothing to do with it, I don’t know.


I updated the Store version which is now 1421.938 and it’s still working as expected in fullscreen.


I made a quick video to show the differences/problems between the Steam & Windows Store version.

At first I launch the Windows Store version, then the Steam version. At the end of the video I press alt+tab: as you can see the game is overlayed in the background.


The Steam windows and Microsoft store versions and very different. MS requires so much crap it’s amazing. One test would be to try a older Steam version and see if that works, that would tell me if I introduced something odd in the new build. I didn’t touch any of the windowing code, so that would surprise me, but it would be a clue.


I’m not surprised it’s that crap… No wonder developers don’t catch the UWP train.

How could I get access to older Steam versions so that this can be ruled out?


A bit long, but interesting