Official Thimbleweed Park Forums

Also stuck in the sewer (but I know my alphabet!)

Hi all,

So, I’m stuck in the sewer. However, I can read the graffiti and I can find the name in the phone book (above ground). The problem is that I can’t call it. Here’s my situation…

  • Female agent stuck in sewer, male above ground.
  • Female agent has vacuum tube but got taken to the sewer before I could give it to the pigeons.
  • Water still flowing from hydrant so male agent cannot get to the Quickie Pal. I think.
  • Male agent has the dime coin but cannot give it to the female agent.

I cannot pass anything between the two agents, or get them talking, as I can’t get to that side of town. I also cannot get a spare vacuum tube from the former cake shop as there’s no dialog left.

What should I do? Do I just have to start again?

@FatBloke Welcome! Thank you for vindicating what I wrote in Under development adventure games that are worth a mention :wink:

I don’t quite recall any specifics I’m afraid. Did you fully explore the town again, including parts and buildings you may have already visited?


You don’t have to.

Something you wrote makes me think you read the solution or asked for hints, but you still can’t find your way out.
I mean you know the quickie pal room might be useful, even if you haven’t seen it yet. So you know something you shouldn’t know.
Let me tell you this: don’t let the solution you read throw you off the course.
Explore the town.
The solution is much easier than you think. I don’t wanna spoil it, since it is so easy you’ll blame yourself if I’ll reveal it.
Let me know.


How do you know there is a Quickie Pal then?

1 Like

Okay, you got me :wink:

I don’t know about the Quickie Pal…at least, not in the game. But I had a good search through this forum before posting, so I had an inkling that there might be a manhole/grating near the Quickie Pal, which I figured was in the part of town that I couldn’t access.

Intriguing! Thanks for that. I will explore the town again, from start to finish, and see what I can find.


Solved! I eventually realised that I could go further right than the diner. I literally slapped my forehead. I’m back on the hunt now…

It's the first time I hear about such issue in TWP, but it happened before...


Eheh… that’s why I didn’t want to reveal it… :wink:

1 Like


1 Like

Loom has at least two of those instances were you can get stuck by not realizing that the screen can scroll further.

1 Like

Same thing in Edna’s room (but on the other side)!
And let’s not forget about a certain puzzle (no spoilers please) in the first part of MI2 we were all stuck on. You know what I mean.

1 Like

I even still get stuck in the cave (with the pool) on replays!

Not sure about the other… oh yes, near the end…:sweat_smile:

1 Like

Oh, you maybe mean the ladder? I didn’t realize it was out of sight and so possibly missed by not scrolling.

Errrr. no. I don’t know. I really can’t recall a difficult puzzle related to screen scrolling in that part of that game.

@Sushi Yeah, you’ll have to jog my memory too…

Well - blurring any potential spoilers as @tasse-tee still never played it and I’d like to have an unbiased fresh opinion on how devious this one really is:
It is the puzzle where you need to find a laundry ticket. If that doesn’t ring a bell, you either used a walkthrough, you played it on easy setting (not sure if that skips this puzzle?) or you’ve suppressed the traumatic memory :sweat_smile:

Indeed there is no scrolling involved, but the solution is equally slap your head

Yes it is! Unless you paid close attention during cutscenes perhaps. Also it is drawn in profile, making it less identifiable as a ladder.

1 Like

I recall the laundry ticket being difficult but not how it relates to the camera (if at all).

I learned about camera issues in MI3 and/or Fate of Atlantis. Checking for them is probably a second nature of sorts, much like defensive saving.

Is this door-related? There is the same “mean” puzzle in DOTT.

1 Like

How you dare?

Exactly, that’s the reason I didn’t get what you were referring to.

Anyway, I liked that puzzle, and didn’t find it unfair. A door which opens by itself so explicitly is too much intriguing not to be involved in one (or more than one) puzzle.

1 Like

Oh yeah, not unfair at all (unlike that other puzzle in MI2 we all hate! :monkey: !!) just slap-yourself-for-not-seeing-the-obvious

1 Like
Official Thimbleweed Park Forums powered by Discourse.