Official Thimbleweed Park Forums

Annoying Twitter window


#1

Every time I log in to this forum a new window appears that forces me to allow Twitter access to my Discourse account. How can I disable that window? I don’t want to connect my accounts.

/edit: I figured out that the Twitter window appears if I confirm my password with enter. So the Twitter button seems to have the focus. But it’s still annoying and it would be great, if that Twitter thing could be deactivated.


#2

I never saw that window.


#3

I have never seen that either. Check your account preferences under “Apps” and see if you have twitter shown there for some reason.


#4

Me neither. Maybe @eviltrout knows the answer?


#5

It’s annoying indeed and it had never been there until last weekend.
I am also surprised about it, because the function “Block pop-up windows” is actually active in my Firefox. It seems to get overridden by Discourse. What a weak function!


#6

Which browser do you use? You can open that window if you click on the blue “Twitter” button in the login form.

The problem is that you activate the window by pressing enter. AFAIK Firefox blocks only windows that the page opens.


#7

Where do I find the “Apps” entry? Can’t find it my preferences … :slight_smile:


#8

It seems to be a bug when the only login provider enabled besides local logins is Twitter.

I’ve logged it on our meta forum and hopefully someone will get a chance to look into it soon:


#9

Is there something I can do with the site config?


#10

No, we realized it was a regression with a recent update. We’ll be deploying you with the fix shortly.


#11

I have an “Apps” Category a the bottom of my preferences, which I thought might be to blame, but based on recent response from @eviltrout, it sounds like that isn’t likely related to the problem.

image


#12

That category is missing in my preferences, “Interfaces” is the last visible category - maybe because I’m using a desktop browser. :slight_smile: You are using the Discourse App in an iOS device?


#13

Yeah, it’s probably only in mine because I linked the Discourse App on my iPad and iPhone to this forum. If you haven’t done that, the section probably just doesn’t get shown at all.