Official Thimbleweed Park Forums

Problem when the mouse is at the right-most side of the screen


#21

That’s a long guide indead :slight_smile: I’ll check that later. Thanks.


#22

Linkfix for the rest of us who do not have access to edit the video:


#23

Ooops, I fixed the link.


#24

I tried to follow the guide but I’m stuck at step 5: typing “steam://nav/console” in my browser doesn’t open Steam, it starts a search in Google instead. It seems the steam hook isn’t registered on my computer.

I read somewhere that by starting steam with the “console” option it would show the console, but again, no luck: it doesn’t show the console.

edit: that’s “-console”, downloading an older version right now…


#25

I tried a few different Steam versions, here are the results:

  • version 1421.958: doesn’t work (that’s current stable version)
  • version 1421.957: doesn’t work (March 1, 2018 – 17:27:54 UTC)
  • version 1420.955: doesn’t work (November 20, 2017 – 15:57:11 UTC)
  • version 1312.861: doesn’t work (April 6, 2017 – 21:10:17 UTC)

#26

Well, that means it wasn’t something I just introduced. I’ve never heard of this issue before and I doubt it’s gone unnoticed for a year. So, I wonder if a Windows update broke something. As I mentioned, I don’t see this issue on my Surface Pro, so I wonder if this is a Surface Book issue (or Surface Book + latest update). I don’t have access to a Surface Book, so I can’t test it right now. I’ll see if someone locally has one.

Thanks for all your effort in tracking this down.


#27

Thanks for the follow up. I wouldn’t be surprised if this was introduced by some update: bugs come, and go, and come back with Windows 10 updates. You never know what can happen.

A new big update is supposed to be released soon: maybe it will make things better…


#28

One of our testers (@Calypso) found this:

Sounds like a similar problem.


#29

Yes, think positive.


#30

Just to be sure I also tested the very first release and the problem is still there.

I guess this has nothing to do with the problem I have but it seems the SDL window of Thimbleweed Park has the WS_EX_ACCEPTFILES flag so can accept drag and drop: I’m not sure this is intented.

The reported size of 3000x2000 is correct: that’s the resolution of the Surface Book:


#31

It seems to be related indeed. The workaround is also the same (but it’s not a solution for me as it makes the app laggy).


#32

@RonGilbert I found a way to reproduce the problem with another computer.

It seems the bug only happens with certain scaling: on my wife’s Lenovo (which is also high DPI 3200:1800), the problem didn’t happen. I checked the scaling setting (see my very first screenshot in this thread) and it was set to 250%: that’s the recommended setting for her computer.

Changing it to 200% (which is the default scaling on my machine) makes the bug appear on her computer as well.

To sum up:

  • Surface Book / 200% (default) scaling: bug

  • Surface Book / 250% scaling: no bug

  • Lenovo Yoga Book / 200% scaling: bug

  • Lenovo Yoga Book / 250% (default) scaling: no bug

So I think that depending on the default setting of the computer’s screen scaling, the bug may or may not appear.


#33

Just to let you know that the problem is still there with the latest Windows 10 Update (1803: “April 2018 Update”).

I had little hope the update would fix it but unfortunately the problem is still there :frowning:


#34

Problem is still there in latest October 2018 update…