Official Thimbleweed Park Forums

Switch version does not save settings


#1

Hey guys, I know this was posted in an older thread but my response there had no answer after almost a month and this issue is consistently hampering my enjoyment of any otherwise excellent game.

It’s not keeping the options saved at all between sessions: volume sliders, ‘Annoying in-jokes’ etc.

This is a 100% repro for me.

Playing on Hard difficulty in English, on a console purchased in December in the UK. No tampering with it or anything, just a straight-up off-the-shelf model.

Steps:

Launch & play.
Change slider volumes to 1/3, turn on ‘in-jokes’.
Save game manually.
Return to Switch home screen using home button.
X -> close.
Relaunch.
Check settings & observe reset options.
I just realised you don’t actually have to be coming from a save game, just seems to reset the state by closing the app.

User profile name is simply “Mike”, so no unusual characters or anything.

Any help would be hugely appreciated! This is quite a persistent bug that is annoying to redo every time I open the game. I didn’t have this problem on PC, so it’s definitely a Switch-only thing.


#2

I haven’t a Switch so I can’t help you. But have to contacted the support? support@thimbleweedpark.com

And maybe @RonGilbert can help?


#3

I have a Switch, playing on Casual in English.
I tried changing one of the volume sliders, turning on in-jokes and saving over an existing file. The settings are retained when I relaunch.

Have you tried saving in an empty slot, if you have any available? Does this happen with your autosave slot too? (I’m not sure what triggers the save, as I don’t use that slot, but I assume changing locations would do this.)


#4

We’re looking into it using your repro steps. Odd that it’s 100% for you.


#5

We tried to repro the issue using your exact steps and were unable to. It’s very perplexing. I just went in and look at the code, and the settings are saved every time you to close the Options menu, so it shouldn’t have anything to do with the save games, or how you exit.

Is the annoying in-jokes the only setting not saved. Can you try just toggling the toilet paper setting and let me know if that is saved? What if you just change volume, are those saved? Do each one separately.

There was a bug in the first version of the Switch where it would not save settings is the game was killed by the OS (starting up a different game before exiting TWP), but that should be fixed in the Dec build. Can you open the Options, and in the lower right corner, there will be a version/build number. Can you tell me what that is?


#6

Who would have known that it’d turn out useful for troubleshooting


#7

Hey Ron, thanks for getting back so quickly!

It was still not saving the individual settings either, which is odd. In the device settings it was version 1.0.2 and the version number is 1419.952 (after a fresh install as well).

All settings are being reverted regardless of whether it’s on a save or not, what slot it’s being saved to etc.

I’m happy to get a video of it if you want, not that I’m sure that will help or not, but yeah, no idea why that would be happening…


#8

A video might help, from first app open to shut down. There might be something subtle happening. The quickest way to test is to open the game, them from the start screen, choose options, set and then quit. No need to even go into the game. We had one other report of this, but it was solved by them creating a new Switch profile. You might want to try that, just as a test.


#9

I’m just linking the original thread for reference:


#10

Hey Ron,

Thanks for getting back so quickly, I’ve got a link to the video here (sorry, it wouldn’t let me attach it on here, apologies about the file size). As you can see, it just doesn’t retain the settings, same if you save the game (the file loaded was saved with the settings correct, as I had put in during the start of the video).

The most frustrating thing is that it is working, and they are being retained, on my wife’s account on the same console…so it seems it just isn’t working on the account in the first slot, or the account that it was bought while logged into.

Anyway, here’s the video of it:


#11
  • Is it also reproducible when you just start the game, change a single option and then quit?
  • Are settings saved if you create a new (3rd) profile and repeat the same above?

#12

Hey,

  1. Yeah, reproducible when you change a single setting.
  2. Yeah, on a 3rd account it still saves the settings correctly like it did on the 2nd account.

So it seems to only be affecting the eShop account that bought it. I also changed the order of accounts to check it wasn’t having an issue with the system ordering of the accounts, but it was still forgetting the options on my one. I can’t see any user-specific settings or anything that would be causing this to happen either.


#13

It’s really odd. The settings are just saved in a normal file, no different from the save games, and it’s saving those. I’m perplexed.


#14

I apologize in advance if my input here is unhelpful and/or unappreciated, I just can’t resist a good debug mystery.

From the description of the problem,it sounds like the file where the settings are stored has somehow become read-only (or perhaps not writable OR readbable). Another profile on the same system works, save games work, just not the save options file. Ron mentioned earlier it happened before and creating a new profile solved the problem, which is also consistent. Ron - if the options file were read only, would the attempt to save the options when closing the options window result in a user-visible error? Would there be a user visible error if there was a problem reading the file? And if the file was not there at all, would that cause a different behavior by the program?


#15

The file being read-only, not saving, or being unable to open would all cause the issue. This has never happened for us, so we can’t debug what the issue is. We do nothing special with that file, it’s treated exactly the same as the save game files, and no one has ever reported a problem with those. One interesting test would be to delete the game from the device and reinstall, see if that clears it up. I don’t know if reinstalling removes user data or not. Might lose savegames. So far, I’ve had 2 reports of this, so it’s not widespread. It’s also possible that it happens more often, but goes unoticed if you’re not chaning settings.


#16

You could update TWP so that it shows a warning in the/at the bottom of the options if the file is read-only, etc. That would be a useful information on other platforms too, especially on Linux.


#17

Switch approval system is a huge pain, it’s not something we want to do just for a quick test or new warning message. This is such an odd edge case, it’s not worth creating a whole error system, so many places in the engine where you’d want to do this, and 99.99% of them are not a problem. Stuff like this is a rabbit hole. I suspect that is a bug in the OS, I highly doubt the file is read-only.


#18

Then do it with the/a next big update.

You don’t have to do this in any possible places. But it would be very helpful if you just test the (existence and rights) of the config file every time the player enters the options. I assume that this would be easy to implement without any side effects/regressions. And as I said above, that test would be helpful on other platforms too, especially Linux.

But you don’t know. Maybe error messages would be helpful. :stuck_out_tongue_winking_eye:

Have the end-user Switches (or what the plural is :wink: ) a debug mode where you can inspect the rights of the files or browse through the files?


#19

speaking of which…:ransome:


#20

It’s unlikely there will be a Switch update in the next 6 to 9 months. The Ransome DLC will be Steam and GOG only due to console rating issues. Switch won’t allow DLC to be rated differently than the game, so we’d have to change the game to M and go through the entire rating process again. Rating the main game as M would kill sales. PS4 and Xbox are the same (although they do make some exceptions for big titles). Sucks, but that’s the state of it.

I know stuff like this is easy to say, but go make and ship a game and you’ll understand why this isn’t as easy as it seems, not from a technical standpoint, but from a there are 500 things to do and only time for 100 of them, so you pick and you’re wrong on 20 of them.