Official Thimbleweed Park Forums

When Games Break

#1

So I figured it was time to make a thread to document my future game-breaks! Feel free to add your own examples of glitches and bugs you’ve discovered in games through experimentation, especially those that cause a crash.

Wanna know the Secret of Breaking Monkey Island?* **

Get Guybrush to read the note from LeChuck while the mug is transforming from one form to another.
Here’s an example! It can also happen in other rooms, and between other phases of the mug’s demise.

:see_no_evil: :hear_no_evil: :skull_and_crossbones:

* I’m playing the Ultimate Talkie Edition. I’d be interested to find out if this can be replicated in other versions.

** More secrets may be uncovered by the time I’m done with this game. Watch this space.

9 Likes
#2

I don’t recall that from the original DOS version. Then again, I probably never tried it. :stuck_out_tongue:

1 Like
#3

Sweet! Did you try typing any commands when the console prompt comes up? I wonder what kind of secrets you can discover in there. :thinking: :thought_balloon:

3 Likes
#4

like… > disp “secret of monkey island”?

nice find @tasse-tee!

2 Likes
#5

No, I didn’t. I’ll give that a try!

1 Like
#6

You can always access it with Ctrl+D (for debug) iirc.

1 Like
#7

I’m pretty famous in my circle of friends for being the one who finds the most unusual glitches and bugs in games :stuck_out_tongue: if I had time to play, I’d contribute a lot to this thread.

2 Likes
#8

When I read that new topic subject, I immediately thought to complete it as:
“When Games Break…, @tasse-tee must be playing them!”
Only to discover she started the topic! :joy:

3 Likes
#9

Looking at the note really is a very unlikely thing to do at this point. I honestly wouldn’t have thought that it could have side effects or even crash the game.
Talking strings with multiple pages were converted to cutscenes in the Ultimate Talkie edition, which might introduce a bug like this, no one catched before.
During testing, we noticed only a single instance where the conversion had an unintended side effect: The first cutscene with Lechuck had the character movements timed wrong, which I tweaked manually to get it right again.

Some questions:
Does it also happen when reading the election poster instead of the note?
Does it happen when talking to anyone instead?
Does any of this also happen with the original version?
Is it only ScummVM, or is the DOS version affected as well?

3 Likes
#10

Most of them are too complex for me to get my head round. Attempting to load another save file, continue, or switch rooms closes ScummVM. But I got a funny message from one command:

image

Ironically, the command does nothing. The music (background noise of the sea) keeps playing after the debug menu opens.

No. But it happens when you try to Use another object that makes the cursor disappear during the dialogue: either of the t-shirts.

I tried it with the cook (dialogue options) and the map seller (no dialogue options). In both cases, the mug goes through its transformation phases during the conversations without crashing the game.

4 Likes
#11

iMUSE was introduced with MI2 so it’s OK that it won’t do anything in MI1.

1 Like
#12

Actually, the enhanced CD version of MI1 was released after MI2 and uses the same engine, thus it does in fact use iMuse. It does not use any of its fancy features which make iMuse special, though.
Then again, the Ultimate Talkie Edition does use some iMuse features, to improve the timing on the title sequence.

It might be, that the ScummVM team didn’t thought of stopping CD audio tracks when you enter “imuse panic”. It is meant to stop MIDI music, which can glitch and then overlap several melodies at once, thus being a pain to the ear when that happens.

2 Likes
#13

Say @LogicDeLuxe, do you know why CTRL-P doesn’t allow me to toggle the Spiffy close-ups?
Also, I seem to be unable to trigger the stump joke.
I am playing the Ultimate Talkie Edition, albeit in my translated version as a playtest.

#14

I encountered this on some PC’s too. Unfortunately, I don’t know what causes it.

Since the stump joke has no voice acting, it is only accessible when “match voice acting” is disabled.

1 Like
#15

Why it doesn’t have voice acting? What other differences there are?

#16

The SE runs on top of the enhanced CD which never had the stump joke. Thus, the actors didn’t have that in their scripts. I ported the stump joke from the DOS floppy version.

Unfortunately, there are a few lines missing which the SE avoided by overriding the original scripts. This include a lot of Stan’s pricings. Fortunately, I managed to splice prices together in realtime, but some of the higher prices couldn’t be done this way. Only the initial offer selection is reduced when “match voice acting” is enabled.
And one of the insults is missing, iIrc.
Reading the amount of money you have have only a selection of comon amounts and some general strings otherwise. “match voice acting” shows the general string as subtitles and will show the original text when disabled.
Also the misspelled random names from the lookout and from LeChuck are only a subset of what the original script could generate. That change is not affected by the “match voice acting” mode.
Also some subtitles with flashing or moving effects where changed to regular subtitles, since those don’t work with voice acting in SCUMM V5.

Over all, Monkey 2 has got more changes in the SE than the first game, which includes a missing number on the wheel of fortune, but mostly, it was to avoid registered trademarks and song lyrics. Also a smoking reference was removed, which is odd, since they didn’t have an issue with smoking in the first game. And of course, the number of bootles of beer on the wall isn’t random in the SE, and they also didn’t voice every possible number, but only a few from the selection downwards.
“Match voice acting” isn’t fully implemented in the Ultimate Talkie Edition of Monkey 2 yet. The game currently avoids unvoiced lines, but should have the original subtitles intact in case of censoring.

For a slight bonus, both games have a few lines with voice acting intact you didn’t even saw in the original game. Those lines were missing due to bugs in the scripts which I fixed. Also the easy mode exclusive lines have voice acting.

3 Likes
#17

Thanks, that’s very interesting. I don’t remember what trademarks and song lyrics where in the original MI2. Next time I’ll play, I’ll check out that version.

#18

Trademarks were quite a few throughout the dialogs. Song lyrics were quoted when looking into mirrors and when inhaling helium. Since those are subtitles only, they are easy to dismiss. I don’t even remember what songs they were from. Obviously, they didn’t dare to let the actor actually sing them.

1 Like
#19

I had a weird glitch in King’s Quest 4 when I played it a couple of years ago…
Somehow it broke so that I didn’t have to do a whole section of the game, I think something to do with a graveyard…
When I looked up the walkthroughs after playing it, it seemed that I had skipped a whole unskippable section that was normally necessary to progress.

2 Likes
#20

Someone tell the speedrunners! :smiley:

2 Likes