Why would anyone open that clock in the bank? Or why having read the development blog can be a cursed blessing

Why would you open that clock in the bank? Fans who followed the blog already knew it can be opened (something I honestly never would have tried if it I hadn’t read the blog). But I immediately closed it again, just because I did not see a puzzle use for it and I didn’t want to solve a puzzle before finding it. And then I completed the game (in hard mode) without having to touch that clock.

Without giving spoilers, did someone find a use or an optional puzzle related to that clock?
At one point, I was thinking its cogs might be a way to open the safe - but I abandoned that idea, knowing the safe was a room that got cut quite early. And then I got a bit sad because I realised that having followed the development blog so closely has somehow limited my imagination and that feeling of unlimited exploring and experimenting like I would have done as a kid without any knowledge on what lies ahead; even if that was a false feeling that only resulted in a lot of “That doesn’t seem to work” responses.

Another thing was picking up a lot of items on the highway, then throwing them away in the garbage bin in the quickie pal bathroom. Then I went back and saw only 1 item re-appearing. So I knew that one was not a red herring (this is not a Sierra adventure after all).
Boy, did I use the broken bottle of ketchup on so many things in Maniac Mansion! But this time, when I saw them in the fridge, I had a good laugh and did not bother to pick them up.

Cursed blessings, I tell ya…

2 Likes

Just because it was opened in an early video, shown in the Blog :smiley:
Just curiosity…

After playing DOTT, I try and open all clocks :smile:

2 Likes

Wait, I don’t remember opening a clock.

You mean there is an easter egg with a clock in TWP?

3 Likes

I think it’s for the same reason I pick up every object without even knowing if and how I will use them. If something can be done in the game, I want to do it. I think it can be classified as a compulsive disorder.

I even opened the clock in the wireframe world.

2 Likes

I do the same. :smile: I was pleasantly surprised when :delores: responded with some comment when I tried to opened the grandfather clock in the Edmund Mansion Mansion. I tried it because it reminded me of the clock in DOTT. :thumbsup:

And yet… I didn’t even noticed the clock at the bank! :open_mouth:

1 Like

I try open everything after Maniac Mansion radio.

2 Likes

Not sure if it is an easter egg… more an abandoned puzzle

Weird, I remember the bank being closed in the wireframe world…

You can even enter the safe in the wireframe world!

You know, I first assumed it was closed because I misinterpreted what Delores said when I tried to open the doors. I was distracted and thought she basically said “I can’t go there, everything is unfinished”. But she actually said “no need to open, just walk through”.

I think that’s what happened to me too! I need to replay some parts asap…

I stole the banker’s paperweight. I was so proud of myself too.

Never found a use for it :frowning:

It took me a few seconds to adapt to the new way the character could enter the buildings (i.e. without opening doors) but after my brain accepted it, I realized that the wireframe world was richer than initially I thought it was.

I hardly did any of that in the first playthrough…in later playthroughs though I found the mechanical bull!