Official Thimbleweed Park Forums

Truberbrook - Adventure game


#41

You probably have been checking that page before, so it is likely to fall open on that page… or just, you know, the ancestors’ spirits at work :ghost:


#42

Someone might’ve, but not me. E.g., the author might have checked up on my surname out of curiosity. (I needed to research the work a bit in light of my doctoral proposal.) Then again, wouldn’t he have his own personal copy without needing to use the university library?


#43

Trüberbrook will be available on Gog:

https://www.gog.com/game/truberbrook_a_nerd_saves_the_world


#44

Release date: March 12th


#45

I’ll definitely get that one. Though whether physical or digital remains to be seen.


#46

Current release schedule:

  • 2019-03-12 digital release (Windows, Mac & Linux)
  • 2019-03-14 physical release (Windows, Mac & Linux)
  • 2019-04-17 Xbox One, PlayStation 4, Nintendo Switch


#47

It’s now available on GOG:

https://www.gog.com/game/truberbrook

and Steam:


#48

If you’re ok with a steam key, you can get a bigger discount here. (-25%)


#49

No Italian translation?

No, Guga, please stop putting yourself in new side projects…


#50

Has anyone tried it yet?


#51

No, but I will soon. :slight_smile:


#52

Waiting 'til Saturday, to see if I can pick up a retail copy.


#53

Yes. Playing the Mac version. Visually nice but my poor i5 struggles. Very laggy mouse movement. The logic around saving your progress / save slots is weird.


#54

I haven’t played this game, but the UI is interesting! If I understand correctly, you only see the objects that it makes sense to combine with the selected room object. a consequence is that it is impossible to combine something in a wrong way, i.e. impossible to get a generic error message (like “that doesn’t work”). I need to understand if this gives away puzzles, and what kind of puzzles are possible and which kind are lost.

[Edit: well, in a sense you lose all the puzzles. because practically all puzzles consist in understanding that an object makes sense with another object… if you only see the objects that make sense, basically aren’t all puzzles automatically solved? maybe not: maybe the puzzle is to understand that , now that you have this new object, it makes sense to backtrack and reclick on some original room object which previously you couldn’t do anything with]

I wonder if this is similar to the secret UI that Ron Gilbert had in mind. (also given that Ron endorsed the game)


#55

At least in the pre-title sequence you can try to use the pliers on the motorbike but will get the message that this does not work.


#56

I see… but in some sense that wasn’t the “generic” error message, if you know what I mean. it was a case where they chose to allow you to try that —the game had considered that possibility. the appropriate response happened to be “it doesn’t work”.


#57

True that. They just added it in as a red herring I guess.
I’ve seen it mentioned somewhere that the target audience is inexperienced p&c gamers and that it’s a fairly easy game, puzzle-wise.


#58

That’s a bit of a disappointment :frowning: Also reviews are mixed regarding the narrative and story. Such a shame, if anything this could have been the perfect game to promote the genre…


#59

What a pity to have to observe how many recent point & click games provide only such reduced UIs!
I wonder if the average gamer really has become too lazy for a more ‘classic’ adventure game.
In my opinion, the absence of dead ends makes those games easy enough. Well, bad puzzle design can still be frustrating, but making the puzzles even more simple is not an appropriate way of rising to this challenge of game design.


#60

I backed this game on Kickstarter and just started playing last night. It’s true the GUI is simplified, but I still feel I the puzzles are reasonably challenging. It avoids long stalls where I need to combine things in nonintuitive ways. I am on the 3rd or fourth ‘chapter’ and I am really enjoying the game. I like the unique pseudo-realistic ‘claymation’ like art style and the voice acting, and also the nice pacing of the game. I particularly like the Twin Peaks vibe, which is quite prevalent.

I reduced the game resolution a bit from max because the default highest res of my monitor was causing a laggy mouse cursor on my somewhat older PC with a lower end NVIDIA GPU.